
 

Tab Panel Magic 3 (TPM3) 

 

TPM3 is the ultimate Tab Panel widget for Dreamweaver. With its rich 

option set and full responsive nature, it is unsurpassed. We hope you 

enjoy using this product as much as we did making it. 

Al Sparber & Gerry Jacobsen PVII 
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2 Managing the User Interface Items 

 

Install the extension 

Look for the extension installer file in the root of the zip archive you downloaded. Double-click the file to install 

the extension. Dreamweaver's Extension Manager will open and you will be prompted to complete the installation.  

For Dreamweaver CS6 and under: 

p7_TPM3_318.mxp or p7_TPM3_318_upg.mxp 

For Dreamweaver CC or higher: 

p7_TPM3_318.zxp or p7_TPM3_318_upg.zxp 

Once the installation is complete, restart Dreamweaver. 

OS X users: If, upon double-clicking the installer, Extension Manager does not properly launch, you have a file association issue. To 

remedy the problem locate the installer file from inside a Finder window and double-click it. 
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3 Managing the User Interface Items 

Work in a defined Dreamweaver site  

Before you begin, make sure you are working inside a defined Dreamweaver web site. This is necessary so that 

Dreamweaver knows how to link required assets. If you are new to Dreamweaver or need to learn how to define a 

web site, follow these simple steps: 

Choose Site > New Site 

Specify local site location  

The Site category of the Site Setup dialog box is the only one you need to fill out to begin working on your 

Dreamweaver site. This category lets you specify the local folder where you’ll store all of your site files. When 

you’re ready, you can fill out the other categories in the Site Setup dialog box, including the Servers category, 

where you can specify a remote folder on your remote server.  

Site Name  

…the name that appears in the Files panel and in the Manage Sites dialog box; it does not appear in the browser.  

Local Site Folder  
…the name of the folder on your local disk where you store site files, templates, and library items. Create a folder 

on your hard disk or click the folder icon to browse to the folder. When Dreamweaver resolves site root-relative 

links, it does so relative to this folder. 
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4 Managing the User Interface Items 

Inserting a New TPM3 Widget 

Tab Panel Magic 3 widgets can be inserted anywhere on your page, even into the content panel of an existing Tab 

Panel Magic 3 widget. Once you have established your insertion point, click the Tab Panel Magic 3 icon  to 

open the interface. Alternatively, you can choose Insert > Studio VII > Tab Panel Magic 3 by PVII.  

The Tab Panel Magic 3 will adapt to the width of the element into which it was inserted—whether that width is 

fixed or flexible. In the absence of a containing element, the widget will stretch the full available width of your 

browser window. You can insert as many individual Tab Panel Magic 3 widgets as you like on your page. Each one 

can be configured independently to set different options and features. Tab Panel Magic 3 widgets on a single page 

can share the same style theme or be set to separate style themes. Each widget can contain any type of content. 

Content panels are directly editable in Dreamweaver Design View using normal Dreamweaver editing techniques. 

-Establish the insertion point for your new Tab Panel Magic 3 widget by clicking in the area of the page where you 

would like the widget to be created.  

-Click the Tab Panel Magic 3 icon  in the PVII Section of Dreamweaver's Insert Bar or choose Insert > Studio 

VII > Tab Panel Magic 3 by PVII. 

Classic Dreamweaver Insert Bar 

 

Dreamweaver Insert Panel 
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5 Managing the User Interface Items 

The Tab Panel Magic 3 user interface will open in the Create New Tab Panel Magic 3 mode.  

 

Configure your widget, set your options, and then click OK to build the widget at your insertion point. 

You can create more than one Tab Panel Magic 3 widget on your page. Add as many as you like. 

Tip: When you insert a Tab Panel Magic 3 widget, all content will be visible and fully expanded in Dreamweaver to make adding and 

editing content a simple task. The Tab Panel Magic 3 functionality can be tested by previewing in your browser. 
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6 Managing the User Interface Items 

Asset Folders 

When you create a Tab Panel Magic 3 widget, the system creates an assets folder named p7tp3 at the same level as 

the page that contains your widget. This folder will contain a JavaScript file, relevant CSS file (or files), as well as 

an img sub-folder that contains the background images used by the CSS. A Fireworks folder will be created at the 

same level as the p7tp3 folder and will contain editable versions of all necessary background images. 

If any of your content panels include a multi-column Content Layout selection then the system will also create a 

p7ehc folder to house the Equal Height Columns script which is used to provide equal height columns if you 

choose a column-based Content Layout option. 

The Fireworks folder does not need to be uploaded to your Web server. 

 

When you publish your site, make sure you upload the entire p7tp3 folder and, if present, the entire p7ehc folder.  
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7 Managing the User Interface Items 

Modifying an Existing Tab Panel Magic 3 Widget 

You can modify any of the existing Tab Panel Magic 3 widgets on your page at any time. 

-Click inside the Tab Panel Magic 3 widget that you wish to modify. 

-Click the Tab Panel Magic 3 icon  in the PVII Section of Dreamweaver's Insert Bar or Insert Panel—or 

choose Modify > Studio VII > Modify Tab Panel Magic 3 by PVII 

Note: If you use a Macintosh computer, Apple bugs will sometimes cause the Modify menu to be inactive (grayed out). If this happens 

to you, use the icon to launch the interface. You can also launch the interface from the Insert menu. The system will open the interface 

in the appropriate mode whether you use the Insert Menu, Insert Panel/Bar or the Modify menu. 

Select Action Dialog 

The dialog box will be displayed to allow you to choose whether to create a new Panel widget nested inside of the 

existing Panel, or to Modify the existing Panel widget. 

 

Note: This dialog only appears when your insertion point is inside of another Panel system. If your insertion point is not inside a Panel 

widget the interface will open directly to the main Panel interface in Create mode. 
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8 Managing the User Interface Items 

The Tab Panel Magic 3 User Interface will open in the Modify Existing Tab Panel Magic 3 mode. 

 

Configure your panels and options and click OK. 

Managing the User Interface Items 

Mode 

Displays the current operational Mode for the user interface: either Create or Modify. When in Modify mode, the 

id of the Tab Panel Magic 3 widget being modified will also be displayed. 

Panels  

This box displays the text for each panel trigger in the Tab Panel Magic 3—one line for each panel or external link. 

Select (click) the line you wish to act on. 

Add 

Click the Add button to add a new content panel. A new line will be created with the default text "Trigger Text". 

The new line will be created immediately after the currently selected line. 
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9 Managing the User Interface Items 

Delete 

Click the Delete button to remove the currently selected line. The content panel will be removed.  

Up  

The Up button will move the selected line in the Panels list up one row. Successive clicks will keep moving the line 

upward, one row per click, until the line is at the top of the list.  

Down 

The Down button will move the selected line in the Panels list down one row. Successive clicks will keep moving 

the line down, one row per click, until the line is at the bottom of the list.  

Trigger Text 

The Trigger Text box will always display the text of the currently selected line in the Panels list. The system will 

display Trigger Text as the default text when first adding a new content panel. Enter or edit the text that you wish to 

display for this panel heading. The box cannot be left blank. 

Note: If an image has been assigned, this box will be disabled (grayed out) and contain the file name of the assigned image. Removing 

the Image Path will re-enable this box. 

Link Only -No Associated Content Panel  

Check this box if you wish to have the selected Trigger Text serve as a normal page link with no content panel 

associated with it. 

Link Path / Browse...  

The Link box is activated whenever the Link Only box is checked. Enter the path to the linked page for this panel 

heading or use the Browse button to open the Select File to Link dialog box. If no entry is made, the system will 

automatically supply a named anchor to the associated content panel. 
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10 Managing the User Interface Items 

Trigger Image / Browse... 

Note: The Image Path box is only used if you are using images for your headings. For text-based headings this box should be left 

empty.  

Enter the path to your image, or use the Browse button to open the Select Image Source dialog box. You can 

change the image at any time by selecting the trigger item in the Panels list and clicking the "Browse..." button. 

Valid image types are: .gif, .jpg, and .png. 

The image you select must always be the default state image. The system will automatically handle image pre-

loading for over, down, and overdown images based on the Image Swap Option you select. Your default state 

image file names can be anything you like. However, you must follow a naming convention for the swap images. 

The naming convention is user-editable so you can adapt it to your workflow. 

Alt Text 

Enter a description (Alt Text) for the related image. If the text on the image is "Products" then Products would be a 

good choice for the description. 

Content Layout 

When adding a new panel you can choose what type of preset content will appear in the panel: 

 Default -A simple paragraph of boiler-plate text 

 2 Columns 50/50 

 2 Column -Sidebar Left  

 2 Column -Sidebar Right 

 3 Column 33/33/33 

 3 Column -Wide Middle 

 4 Column 25/25/25/25 

Note: This option is available ONLY for newly created panels, it will unavailable (grayed out) for any existing panels. 
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11 Options 

Options 

These settings are applied to the current Tab Panel Magic 3 widget. Other Tab Panel Magic 3 widgets on the same 

page can have different options.  

Controls 

The user interface allows you to choose which control sets will be used. You can choose to use one control set, no 

control sets, all control sets, or any combination. 

Prev/Next 

Check this box to display a set of Previous and Next arrows on the edges of the panel. The Previous arrows will 

display on the left side of the panel, while the next arrow will display on the right side of the panel. When using the 

Vertical Slide animation these will change to Up and Down arrows displaying at the top-right and bottom right of 

the panel. 

Hide Tabs 

By default the Tab triggers are displayed at the top of the panel. Check this box if you wish to hide the Tabs. 

Toolbar 

An optional Toolbar can be displayed, either Above the panel or Below the panel. This Toolbar will contain the 

Paginator and/or the Pause/Play control.  

Paginator 

Check this box to display the Paginator in the Toolbar. 

Pause/Play 

Check this box to display the Pause/Play button in the Toolbar. 
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12 Options 

Page Load 

You can configure how Tab Panel Magic 3 sets up when the page first loads into the browser.  

Start With Panel 

Enter the number of the panel which you would like as the current panel when the page first loads. 

Start With Random Panel 

Select this option if you wish to have the system randomly select a panel to open. Each time the page loads into the 

browser a random panel will be selected. 

Auto Play on Startup 

Check this box if you want to have the panel rotator start automatically when the page first loads. 

Tip: If you have opted to not have any controls or a toolbar then do make sure that Play on Startup is selected. 

Auto Play Mode 

The Tab Panel Magic 3 includes an automated panel rotator system that will display each panel in succession, 

starting with the currently active panel. The system also includes a Control Behavior that allows you to control the 

Rotator actions externally. 

Choose one of these Rotator Modes: 

Auto Reverse 

With the Auto Reverse option enabled, when the last panel is reached, the system will switch to the previous panel 

and continue playing in reverse order until it reaches the first panel. Then it will reverse again, advancing to the last 

panel—and so on. 
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13 Options 

Loop: 

The Rotator will display each panel in successive order from first to last. When the last panel has been displayed it 

will switch back to the first panel and continue playing through the panel list. 

Display Time 

This controls the amount of time each panel is displayed during the rotation, in milliseconds. The default is 5000ms 

(5 seconds). To display each panel for 8 seconds, for example, enter 8000 into the box. 

Show Initial Panel for 

This controls the amount of time the first panel is displayed. During page load it is often desirable to allow the first 

panel to be displayed slightly longer than the other panels to give the rest of the page assets a chance to load. The 

default is 8000ms (8 seconds). To display the first panel for 12 seconds, for example, enter 12000 into the box. 

Auto Play Cycles 

Play Continually 

This option allows the Rotator to play through the panels indefinitely. It will not stop unless the user clicks the 

pause button (if you've made it available). 

Number of Cycles 

Enter the number of times you wish the Rotator to play through all of the panels. By default this box is disabled and 

the Play Continually option is turned on. To activate this box uncheck the Play Continually option and enter a 

number in the box. 

End Cycle On 

This allows you to choose the ending panel for the Rotator. If you've set a Number of Cycles, when the Rotator has 

completed the assigned number of rotations it will stop on: 

 Last Panel: The Rotator will stop at the last panel in the Panel list. 

 First Panel: When the Rotator reaches the last panel it will loop back and stop at the first panel in the 

Panels list. 
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14 Options 

Triggers 

Enable Mouse Over on Triggers 

Check this box to allow mouse over activation of the Trigger Panel links. The associated panel will open whenever 

the user moves his mouse over the Trigger link. The click behavior to open the panel will still remain enabled. 

Mouse Over is only available with animations 0, 1, and 2 (see note below). 

Note: This option is disabled whenever the Animation selection is 3-Fade, as this animation cannot work effectively in a mouse over 

environment. 

Scrolling 

The TPM3 system can automatically provide scrolling control arrows when the number of triggers is such that they 

will not all fit within the width of your layout container. This allows you to add as many triggers and panels as you 

like and still have the triggers fit into the allocated space. If you turn this option off and your triggers do not fit on 

one line, they will wrap to multiple lines. This option's animation speed can be adjusted using the Duration box.  

 None: Scrolling is disabled and no scrolling arrows will show. If there are more Tabs than can fit in one 

row then the Tabs will wrap to a second row to assure that all of the Tabs are visible and accessible to 

the user. 

 Auto Tab Positioning: Scrolling is enabled. Scroll arrows will show at the left and right of the Tabs 

row. When scrolling right the scroller will align the first Tab in the next series to the left of the Tab 

viewport. When scrolling left the scroller will align the last Tab in the next series to the right of the 

viewport. This assures that each tab is fully visible at least once through a complete scrolling session.  

 Normal Scrolling: Scrolling is enabled. Scroll arrows will show at the left and right of the Tabs row. 

The scroller will advance the Tab row by the width of the Tab viewport. No Auto Tab positioning is 

performed. This scrolling mode is the ideal choice when using panels for the Tab triggers. 

Duration 

This option allows you to control speed for the trigger Auto Scrolling animation. Duration defines the total 

amount of time that the scrolling will run, in milliseconds, regardless of a trigger panel's dimensions. The default 

250 (a quarter of a second) is fine in most cases. Lower the Duration setting and the scrolling will be faster. Raise 

the setting to make the scrolling slower. 
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15 Options 

Current Marking 

These settings control the operation of the included automatic Current Marking system. 

Enable 

Check this box to enable automatic current marking (highlighting) of links in your widget. The system looks for 

links in the widget's panels that match the current page URL (address). When a match is found, the link is 

highlighted and the panel that contains the link is set to be the currently active one. The system assigns a special 

style class named current_ mark to this link and also to its associated Trigger Link. This provides a visual "you 

are here" indicator.  

For detailed help on the Current Marker and Advanced Current Marker features, please see the main TPM3 Help 

Files. To access them, open the TPM3 interface in Dreamweaver, as if you were going to create a widget... then 

click the Help button. 

Note: This box must be checked in order to use the Advanced Current Marker features for the widget. 

Include URL Parameters in Match 

This option controls whether the automatic current marking feature will include any URL parameters in the page's 

address when looking for a matching link in the widget. Check this box if you wish to have your URL parameters 

included in the match criteria. 

Animation 

You can choose from 3 animation methods or animation can be turned off. 

Animation List 

 

Duration 

This option allows you to control the animation speed. Duration defines the total amount of time that the animation 

will run, in milliseconds, regardless of a content panel's dimensions. The default 300 (a bit less than one third of a 

second) is fine in most cases. Lower the Duration setting and the animation will be faster. Raise the setting to make 

the animation slower. 
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16 Options 

Image Swap Options 

The system supports using images for any of the Trigger links and is designed to automatically handle pre-loading, 

swapping, maintaining states, and assigning a current marker. This automation requires that you follow the image 

file name convention. The system supports up to 3 different image states.  

Select the Swap Option that you would like to use: 

 Single Image Only: Choose this option if you are using just a single image and do not want any image 

swap actions on any of the trigger states.  

 Normal and Over: Choose this option if you are using two images: one normal image and one for the 

over (hover) state. The over state image will also be used as the open (down) state and current mark 

images. 

 Normal, Over and Open Images: Choose this option if you are using three images: one normal image, 

one for the over (hover) state, and one for the open (down) state. The open state image will be used for 

the current marker images.  

Note: Be sure to choose the option carefully to match the number of image states you are using. The system will pre-load the various 

state images based on this selection. 

Rollover Open State 

This controls the swap action when the trigger link is in its open state. The system will swap to the over image if 

the trigger link is in the open state and you have a 3-state swap option set. Uncheck the box if you want to disable 

this swap action. 

Rollover Mark State 

This controls the swap action taken when the trigger link is in its current marked state. The system will swap to the 

over image on rollover if the trigger link is in the current marked state and you have a 3-state swap option set. 

Uncheck this box if you want to disable this feature.  
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17 Options 

Style Theme 

Tab Panel Magic 3 comes with a variety of pre-defined CSS style themes. Choose a theme that best approximates 

the look you desire. You can later make edits to the style sheet to fully customize your Tab Panel Magic 3 widgets. 

You can change to a different style theme at any time without affecting the contents of the Tab Panel Magic 3 

widget.  

 

A preview of the selected Style Theme is displayed to the right of the Style Theme select list. This Preview will 

change whenever you select a different Style Theme. 

Command Buttons 

The following command buttons are available. 

 

OK 

When you are done, click the OK button to build the Tab Panel Magic 3 widget. The system will verify your 

selections and alert you to any problems that need your attention. If there are no problems, the interface will close 

and a Tab Panel Magic 3 will be added to your page or updated—depending on whether you were in Create mode 

or Modify mode. You can then preview in a browser to operate the Tab Panel Magic 3 and check its functionality. 

Tip: To make further changes, click inside a Tab Panel Magic 3 to open the interface. 

Cancel 

Click the Cancel button to completely abort the current operation. This will close the interface and no changes will 

be made to your page. 

Help 

Click the Help button to open the associated Help File in your browser. This page can remain open for easy 

reference while you continue working with the Tab Panel Magic 3 interface. 
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18 Options 

Converting Previous Versions of TPM to TPM3 

The TPM3 system can convert an existing Tab Panel Magic 1 widget to a TPM3 widget. Conversion is as easy as 

clicking inside the existing TPM1 or TPM2 widget and opening the TPM3 interface. 

Place your cursor inside the existing TPM1 or TPM2 widget and open the TPM3 interface. The system will detect 

that your insertion point is inside a TPM1 or TPM2 widget and the Convert from Tab Panel 1 (or 2) interface will 

open.  

 

Choose an Action 

1. Click the Convert to TPM3 button to launch the Conversion process.  

The system will open the TPM3 Modify interface populated with the existing Trigger and Panel data from your old 
widget. Existing Style and Animation options will be reflected in the UI. Make changes and set new options as 

desired, then click OK to finish the conversion. The original widget markup will be replaced with TPM3 markup. 

The original style sheet link will be removed and a new TPM3 style sheet will be linked in its place. The old script 

link will be replaced by a link to the TPM3 script. 

2. Click the Create a new TPM3 Panel inside TPM1 (or 2) button to launch TPM3 in Create mode.  

The system will create a new TPM3 widget at your insertion point inside the existing widget. 

Tip: When you convert an older widget, its original style theme will be used in default TPM3 form. If your old widget's theme was 

customized, you will need to edit the new TPM3 theme's style sheet. In most cases, this should be a fairly easy task of changing a few 

background-color and color property values. If your CSS skills are not up to the task, contact us or post on our forum and we will be 

happy to help. 

  

http://www.pviiforums.com/
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19 Options 

Removing an TPM3 Widget 

The TPM3 system includes a Remove command that allows you to quickly and thoroughly remove an existing 

widget from your page. Using this command will ensure that there are no code corruptions or remnants left on your 

page, which can easily happen if you attempt to remove the widget manually. 

Open the Remove interface  

-Open a page that contains one or more TPM3 widgets. 

-Choose Commands > Studio VII > Remove Tab Panel Magic 3... to open the Remove interface.  

Note: The Remove option will be unavailable (grayed out) if there is no TPM3 widget on the page. Some Mac systems have 

compatibility problems with Dreamweaver. If the Remove command is grayed out and inaccessible, download and install this command: 

Return False Fix. After installing it, restart Dreamweaver and your menus will be accessible. 

The Remove Tab Panel Magic 3 interface will open. 

 

The interface will provide a listing of all the TPM3 widgets on your page. The list will display the root ID for each 

widget. From the listing, select the widget that you wish to remove. You can remove one widget at a time. 

Tip: If you are unsure about which widget relates to which ID, click the Cancel button and switch to Code View. In Code View, locate all 

IDs that begin with p7TP3. The opening DIV tag for a TPM3 widget looks like this: <div id="p7TP3_1" class="p7TP3-01 p7TP3"> 

What will be removed  

The system will remove the HTML markup for the selected widget, along with the markup for any widgets nested 

inside of it. The system will also remove the link to the relevant CSS files—if no other widget on the page is 

using those files.  

If there are no remaining TPM3 widgets on your page, the system will also remove the link to the TPM3 

JavaScript file. 

What will not be removed 

The system will not remove the p7TP3 assets folder, which may be in use by widgets on other pages. This also 

ensures that you will not lose any customized CSS files or images. 

http://www.projectseven.com/go/returnfalsefix
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20 Options 

TPM3 Image File Naming Convention 

TPM3 supports the use of image-based trigger links – with preloading, swapping, multiple state management and 

current-marking automatically handled. The system supports up to 3 different image states: 

 Normal - the base image 

 Over - appears on hover 

 Down - appears when the related panel is open 

The system automatically loads the appropriate image according to the Image Swap option selected in the User 

Interface. When you choose an image in the TPM3 interface, you only choose the Normal (base) image. The 

system will look at your Swap Options and, if additional images are required, they will be located automatically in 

the folder that contains your Normal state image. This automation requires that you follow an image file naming 

convention. Your Normal image file name can be anything you like—but you must follow a naming convention 

for the Over and Down state images. If your Normal image is named myButton.gif, the following conventions 

must be used: 

 The Over image that displays on hover would be named: myButton_over.gif  
 The Down image that displays when its associated panel is open would be named: myButton_down.gif 

Tab Panel Magic 3 Default Naming Convention: 

 Normal Image: myButton.gif 

 Over Image: myButton_over.gif 

 Down Image: myButton_down.gif  
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21 Options 

External Linking and Bookmark Support 

An opener detection system is included that allows you to set up links with special parameters that will load a page 

and also trigger a specific panel in a TPM3 widget on that page. The opener will look for the TPM3 widget 

number, an underscore, and the TPM3 content panel number. There are 2 methods available: 

 Anchor Method: The system will look for "#TP3" plus a panel reference after the anchor. The anchor 

index.htm#TP31_4 will trigger panel 4 in the first TPM3 Widget on the page.  

 URL Parameter Method: The system will look for "TP3=" in the URL parameter. The URL 

parameter index.htm?TP3=2_4 will trigger panel 4 in the second TPM3 Widget on the page. You can 

then give out the link so people can go directly to your specific content panel. 

Note: This feature is meant to be used on links to your page from external locations—not on links that are in your page. If you want to 

add links on your page that control the panels, you would use the Control Behaviors described below. 

CSS Editing 
TPM3 themes utilize advanced and modern CSS, resulting in beautiful designs that are remarkably easy to 

customize—without having to worry about editing complex background images. For CSS documentation, please 

see: 

The TPM3 Tutorials Page 

Progressive enhancement 
Tab Panel Magic 3 employs the concept of progressive enhancement. We start with well-formed code that 

displays all content in all devices. Then we use CSS3 for rounded corners, shadows, and animated transitions. We 

also use CSS3 media queries to reflow multi-column content inside your panels for optimal rendering on 

smartphones. These effects are deployed in ways that enhance modern browsers and devices while assuring an 

attractive and accessible presentation in older browsers. 

  

http://www.projectseven.com/products/tools/tpm3/tutorials/index.htm
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PVII Tab Panel Magic 3 Behavior - Control Actions 

The Control Behavior allows you to configure a link anywhere on your page to remotely operate any Tab Panel 

Magic 3 widget on your page.  

Available Control Behavior Actions 

 Open First Panel  

 Open Previous Panel  

 Play (Resume)  

 Pause  

 Open Next Panel  

 Open Last Panel  

 Open Panel Number 

Manually applying a Control Action 

When working within Dreamweaver you can use the automated interface-driven Behavior to assign any of the 

control actions. There are times when you may want to manually assigning a control action, either for use in 

external scripts or when building pages dynamically. The control action function call will look like this: 

P7_TP3ctrl('p7TP3_1','play') 

 The first argument is the ID of the Tab Panel Magic 3 root div.  

 The second argument is the control action you wish to apply. 

The HTML markup for a typical text link with a control action applied would look like this: 

<a href="#" onclick="P7_TP3ctrl('p7TP3_1','play')">Control</a> 
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23 Options 

The available Control Actions are: 

 P7_TP3ctrl('p7TP3_1','first') - Open First Panel  

 P7_TP3ctrl('p7TP3_1','prev') - Open Previous Panel  

 P7_TP3ctrl('p7TP3_1','play') - Start or Resume Auto Play 

 P7_TP3ctrl('p7TP3_1','pause') - Pause the Auto Play 

 P7_TP3ctrl('p7TP3_1','next') - Open Next Panel  

 P7_TP3ctrl('p7TP3_1','last') - Open Last Panel  

 P7_TP3ctrl('p7TP3_1',x) - Open the specified panel number, where x is the number of the panel  

Creating a new Control Actions behavior 

 Select (click) a text link or panel to act as the behavior Control.  

 Open your Dreamweaver Behaviors Panel (Shift + F4)  

 Click the plus sign (+) on the Behavior Panel.  

 Choose Studio VII > Tab Panel Magic 3 > Control Actions to open the interface.  

 Select the widget you wish to act on.  

 Select the action.  

 Click OK to apply the behavior.  

Modifying an existing Control Actions behavior 

 Select the element that contains an existing Tab Panel Magic 3 Control behavior.  

 Double-click the Tab Panel Magic 3- Control Actions behavior in the Behaviors Panel to open the 

interface.  

 Select the widget you wish to act on.  

 Select the action.  

 Click OK to apply the revised behavior.  
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The Interface 

The Tab Panel Magic 3 -Control Actions interface allows you to select an action to apply. 

 

The Interface Items 

Tab Panel Magic 3 

The interface contains a listing of all of the Tab Panel Magic 3 widgets on your page. The list will display the ID of 

each widget. Select the Tab Panel Magic 3 you want to control.  

Tip: If you are unsure about which widget relates to which ID, click the Cancel button and switch to Code View. In Code View, locate all 

IDs that begin with p7TP3. The opening DIV tag looks like this: 

 

<div id="p7TP3_1" class="p7TP3-04 tools-top"> 

Action 

Select the action you want to apply.  

 

First Panel  

This will display the First panel.  

Previous Panel  

This will display the panel that comes before the currently displayed panel. 
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Play 

This will Start or (resume) the Auto Play Mode. 

Pause 

This will Stop (or pause) the running Auto Play mode. 

Next Panel  

This will display the panel that comes after the currently displayed panel. 

Last Panel  

This will display the last panel. 

Open Panel Number... 

This allows you to select the exact panel to be displayed by entering the Panel Number. 

Panel Number 

This box is active only when the Open Panel Number action is selected. Enter the number of the panel you wish 

to display. 

The Interface Control Buttons 

OK 

When you have made your selection, click the OK button to apply the behavior. By default the behavior will be 

applied to the onClick event of the text link or panel. You can change the event by selecting the desired event in 

the Behaviors panel.  

Cancel 

Click the Cancel button to completely abort the current operation. This will close the interface and no changes will 

be made to your page. 

Help 

Click the Help button to open the associated Help File in your browser. This page can remain open for easy 

reference while you continue working with the Tab Panel Magic 3 interface.  
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Support and Contact info 

PVII quality does not end with your purchase - it continues with the best customer support in the business. 

PVII Knowledge Base  

The PVII Knowledge Base is an online PVII application allowing you to access dozens of Tech Notes, tips, and 

techniques relating to our products, as well as to general web development issues. 

Open the Knowledge Base 

PVII Communities 

PVII maintains separate and distinct Web Forum and Newsgroup communities. We do this to ensure you always 

have access via your preferred medium and device. 

1. The PVII Web Forums 

The PVII Web Forum is a modern browser-based community, accessible to both desktop and mobile devices and 

requires no additional software or plugins. 

Visit The PVII Web Forum community now... 

2. PVII Newsgroup forums 

The Project VII Newsgroup is available via private and secure NNTP servers. In order to subscribe to a newsgroup 

you must have a newsgroup-capable client installed such as: 

 Mozilla Thunderbird 

 Windows Live Mail 

 Windows Mail/Outlook Express 

 Opera Mail 

 Entourage 

Server: forums.projectseven.com  

If you have another newsgroup-capable program that you are using, please see its documentation to learn how to 

add a new newsgroup account. 

  

http://www.projectseven.com/support/questions.asp?
http://www.pviiforums.com/
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RSS News Feeds 

Keep up with the latest news the minute it's released by subscribing to our RSS news feed. If you are not sure how 

to subscribe, please check this page: 

PVII RSS Info 

Before you Contact us 

Before making a support inquiry, please be certain to have read the documentation that came with your product. 

Please include your Dreamweaver version, as well as your computer operating system type in all support 

correspondence. 

E-Mail: 

support@projectseven.com 

Phones: 

330-650-3675 

336-374-4611 

Phone hours are 9:00am - 5:00pm Eastern Time U.S. 

Snail mail 

Project Seven Development 

339 Cristi Lane  

Dobson, NC 27017 

http://www.projectseven.com/xml/index.htm
mailto:support@projectseven.com
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